Jump to content
Xisto Corporation
iGuest

Apache Tutorial: Enable mod_rewrite In Windows A brief action guide to enable mod_rewrite in Windows

Recommended Posts

Hi everybody,

If you are using Windows OS and want to enable mod_rewrite module here is how to do it.

This is the general configuration guideline both for Windows and Linux server:

1. Find the httpd.conf file (usually you will find it in a folder called conf, config or something along those lines)

2. Inside the httpd.conf file uncomment the line LoadModule rewrite_module modules/mod_rewrite.so (remove the pound '#' sign from in front of the line)

3. Also find the line ClearModuleList is uncommented then find and make sure that the line AddModule mod_rewrite.c is not commented out.


For Windows, find the following section in httpd.conf file:

 

DocumentRoot "C:/path/to/my/root"

#

# Each directory to which Apache has access, can be configured with respect

# to which services and features are allowed and/or disabled in that

# directory (and its subdirectories).

#

# First, we configure the "default" to be a very restrictive set of

# permissions.

#


Now modify the option for AllowOverride to look like this:

 

<Directory />

Options All

AllowOverride All

</Directory>

 

This small modification in httpd.conf file will enable mod_rewrite in Windows server.

An excellent website that gives in-depth discussion on mod_rewrite is http://www.doriat.com/
'>Doriat.om- Mod_Rewrite Tutorials Board.

 

Regards,

Sid

Share this post


Link to post
Share on other sites

the httpd.conf is not accessible on windows server apachie?

Apache Tutorial: Enable mod_rewrite In Windows

 

I have been tring to get a mod_rewrite going for weeks and can not get pass the modification of this file. The tech guys say everything under the sun but no one noes anything about having acces to this file on the window server??

Thanks

Jim

Share this post


Link to post
Share on other sites

I have been tryng to get a mod_rewrite going for weeks and can not get pass the modification of this file. The tech guys say everything under the sun but no one knows anything about having access to this file on the window server?? Any help would be greatly appreciated. Further: I need to use mod_rewrite to change a query sting from web to something like, web - so search engines will like me. I use Frontpage2003 and apache windows server, I have turned off front page extentions. and have made a .htaccess file. I have tried to find a httpd.conf to edit but no luck. I have not seen any evidence that anything I have tried even works at all. I need help with the first steps in getting mod_rewrite to do anything at this point. Thanks Jim

Edited by OpaQue

Share this post


Link to post
Share on other sites
Apache mod_rewrite on local XPApache Tutorial: Enable mod_rewrite In WindowsReplying to sid.CalcuttaReplying to sid.CalcuttaActually, for security leave default Options FollowSymLinks AllowOverride All Order deny,allow Deny from allChange only next section below to set rules for your server directory (where you ut your web site files) only:This section easy to miss behind long comments. # comments comments blablablaOptions FollowSymLinksAllowOverride AllAllow from all # blablablaIt works fine on my XP.The other similar section below must be left as default to protect Apache from accidental destruction: AllowOverride None Options None Order allow,deny Allow from allTo see how block/allow specific locations with “Allow from” or “Deny from” see http://forums.xisto.com/no_longer_exists/ cause you need LoadModule rewrite_module modules uncommented and restart Apache.-reply by Dimitri

Share this post


Link to post
Share on other sites
enabling mod rewrite in apache windows.Apache Tutorial: Enable mod_rewrite In Windows

I have noticed my httpd.Conf and got some dissimilarities with the steps mentioned here.

1. There is no line with "ClearModuleList"in httpd.Conf

2.  There is no word "mod_rewrite.C" in httpd.Conf

I am using Apache/2.2.8 (Win32) PHP/5.2.0

-reply by Goutam Reja

 

Share this post


Link to post
Share on other sites
enabling mod rewrite in apache windowsApache Tutorial: Enable mod_rewrite In Windows

Thanks for this, although I'm still experiencing a problem with url rewriting this article is helpful.  My httpd.Conf file doesn't contain the ClearModuleList instruction as well.  I'll figure out where I need to add the ClearModuleList and hopefully that will fix the problem.

Thanks,

-reply by James Radford (Web Developer)

Share this post


Link to post
Share on other sites
huh? I confusedApache Tutorial: Enable mod_rewrite In Windows

So... How to make the apache under windows could eventually accepting mod_rewrite.So ?I also already tried out some steps mentioned before but ending with no luck... OMG :(

-reply by gugum

Share this post


Link to post
Share on other sites

Ahem! Brrm! "Run Linux" is not an acceptable answer to a topic named "XXXXX Windows" :unsure:

my apologies... didn't read the initial post properly

last time i used WAMP Server, mod_rewrite was one of the options which can be toggled by right clicking the WAMP Server icon on notification area... probably under settings or options...

i wonder if .htaccess applies on IIS as well?
Edited by manuleka

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.