Jump to content
xisto Community
Sign in to follow this  

Php Help

Recommended Posts

Are all these files put into folders ? Because you have to include the /FOLDER/before the file. I think. Upload the sub directories ? I think so... I load every thing it gives you even the readme's if thats what your talking about lmao.I always have that problem but I seem to only know what to do myself.. sorry no can do :D

Share this post

Link to post
Share on other sites

Folders are set to 755 and files are set to 644. Someone told me to do a test.php file and run it. I did and it gave me this:


Im giving you the url because the page is too big. Someone said the problem was my 'include_' path'. but im not so sure.

Is anyone willing to check my cPanel and look around, cuz im totally lost now.

Share this post

Link to post
Share on other sites

biotoxic, yes, your sub-directories and the files to be used for that PHP script you

intend to run SHOULD be completely uploaded.


from a previous post i made about DB problems:

let's do a rundown of things which you may have missed. upload ALL your files in

their appropriate folders. then:


1. go to your cpanel.

2. go to mysql page, and click on phpmyadmin on the bottom part of the page.

3. after phpymyadmin pops up, create a new MYSQL database on the left panel.

NOTE: your db will be prefixed with your subdomain_ (example: biotoxic_mysqldb)

4. close phypmyadmin. refresh mysql page. your new database should appear there.

5. check that you have an existing mysql user on the bottom part of the page.

if none exists, create one. it will be prefixed again with your subdomain_ (remember the password you use here).

6. Grant permissions on a MySQL database to a MySQL user. (just above the

existing mysql user in #5). leave Privileges setting as it is. then toggle to grant

permission of a USER to the MYSQL DB you created earlier.

7. After page refreshes, you would see a set of connection strings applicable to

the DB. Check the PHP syntax there.

Example: $dbh=mysql_connect ("localhost", "yoursubdomain_dbusername", "<PASSWORD HERE>") or die ('I cannot connect to the database because: ' . mysql_error());

mysql_select_db ("yoursubdomain_dbname");


8. Proceed with setup of your php script at this point with the details you now have.


Mysql database host (try 'localhost' if you are not sure): localhost

Your mysql database username: yoursubdomain_dbusername

Mysql database password: password

Name of your mysql database: yoursubdomain_dbname

Full path to the folder where the scripts live. It should be correct value so please don't change it if you are not 100% sure it is incorrect. No trailing slash.: (see GENERAL SERVER INFORMATION on the lower left side of your cpanel)



that should cover it all, i guess

Share this post

Link to post
Share on other sites

The DB isnt the problem i dont think. Its able to connect and everything. The DB is called biotoxic_try.Its just those strands of errors that im getting now. Its as if the folders are wrong, which they arent. Everything is as it is.Please, if you would, check my cPanel and check for me, just incase im wrong. Post back if you agree to this, and ill pm you my pass for the cpanel and mysql db.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.