Honesty Rocks! truth rules.

Firefox Progressively Consumes Cpu Cycles Over time, Firefox uses more of the processor until it crashes.

HOME      >>       Websites and Web Designing

bass insight

I am running Firefox 3.6.3 on Windows Vista. I have discovered that over a span of twenty to forty minutes of running Firefox, it uses more and more of the processor, until it reaches 100% and eventually crashes. Once the program uses up the processor, there is nothing I can do to reverse the process except to close Firefox. Even if I close everything but a blank tab, the processor use continues; I have to close the program. Thankfully it only uses up one processor core (out of two on my laptop), but it's still very bothersome.This seems to be a common problem. Most of the fixes I've found involve telling Firefox to disable Javascript. This works, but I am designing a website that uses javascript, so I would really like to be able to repeatedly view my page on Firefox with javascript enabled, and without having to close and restart the program over and over.Does anyone have any suggestions?


yordan

Your firefox seems to have a problem.
I am using Firefox on Vista and my cpu is used 1% right now. Maybe it depends from what you are doing, including your javascript things.
I would suggest two things.
1) Boot your computer, and use firefox to go to the Xisto homepage and during half an hour do nothing except reading posts on the forum, and tell us what happens.
2) Close Firefox, and use the portable version (take it from here : http://portableapps.com/apps/internet/firefox_portable )
you unpack it somewhere in a folder of your computer and you run it from there. it has no installation, it puts nothing in the register table, so it is not harmful for your Vista system : if you don't like it you simply remove the folder. The important thing is that it will start with default setting, it will not be influenced by your installed version. And if you do something wrong, remove the unpacked folder and restart from scratch.
Please tell us the result of these two tests.
Regards
Yordan


rvalkass

You say disabling JavaScript works, which implies the problem lies with some JavaScript that's being run. As it happens even when you've only got a blank tab open, that would suggest the problem could be with one of your installed add-ons. Take a look through the list and disable them one at a time, starting with the most recent (if you remember what order you added them in). Each time you disable one, close and restart Firefox and see if the problem remains. Hopefully you will find that disabling one particular add-on solves the problem. Go to that add-on's web page and file a bug explaining what happens.


yordan

And also try the portable version of Filezilla : it's completely independent from your computer install, so it has no plugin when freshly unpacked. And you can compare with the one installed on the computer.


wutske

Also, very important, make sure that you have the latest version of firefox and all the extra plugins installed :) .


FirefoxRocks

Also try the new Firefox 3.6.4 with Lorentz. If it is OK then we know it is a problem with a plug-in such as Adobe Flash, Microsoft Silverlight or Apple QuickTime. Firefox does consume quite a bit of memory though, ever since version 1.5 or 2, hopefully it will improve with the Electrolysis project/application tabs (moving towards separate process per tab like IE8 and Chrome).


grim reaper1666

my firefox wth loads of tabs open is not a resource hog. i don't like internet explorer because of how it has roots which extend into your system files. this is something which is internet explorer acting like a doorman to viruses saying welcome conflicker c has a nice time. my firefox only uses 3-10% of my cpu and 150,000k of my memory. this is only a small impact on my 4gb of memorey. although i am planning on geting another 4 gb to fill the other 2 slots on my motherboard since it has 4 spaces. i might even invest in 4 4gb sticks since my computer can handle up to 16gb of memory.