Jump to content
xisto Community

Can't Add Smb Printer due to password

Recommended Posts

This is the situation. I have a HP Laserjet connected to my main pc which runs windows XP. I have this printer shared so I could use it on my laptop (laptop doesn't have ltp port ;) ), but I can't seem to add it because my password contains an '@' .
The problem is that you usualy add an smb printer as


so what I get is

Obviously, two @ in the url aren't possible, so my question is, is there another way to pass the password ?

Share this post

Link to post
Share on other sites

Did you try protecting your @ by a \ ?I would try the following :smb://my_name:my\@containingpassword@ not, try with quotes :smb://my_name:"my@containingpassword"@ didn't have this kind of problem yet, but this is the way I would try to workaround it.Of course, another way of cheating is creating another real user, with a very complicated password (without the @ sign) on the Windows machine. Then, from your laptop, you could use this username:password (for instance demo:demo) for attaching the printer.RegardsYordan

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.