Jump to content
xisto Community

Boot Menu Has A Stuck Os Remove it right away with this trick.....

Recommended Posts

This is a tutorial explaining a way to remove a stuck OS option from boot menu after the removal of that operating system.

For eg....
if you had a windows xp and windows vista both installed on the hard-disk and due to some reason you have to remove vista.. You can only do it by deleting the windows vista folder from the drive or if installed on other drive you can do is format it. But again when you start the system you get the boot menu offering you both windows to be started although the vista will not startup...

To remove this stuck windows vista option follow these steps...
Step 1:- Right click the my computer icon and open properties.

Step 2:- Go to the advanced tab.

Step 3:- Click settings in Start up and recovery.

Step 4:- In the system start up category choose edit button.

Step 5:- There you will find two lines starting with something like multi() and all. Here each line represents each windows operating system boot option at boot menu.

Step 6:- Read the whole line and you will find the name of each operating system written, delete the line which have windows vista written on it. Save the file and close it.

Step 7:- Reboot the PC and now you will not get the option again.

An alternative method....

Till step 4 follow the same procedure but don't open the edit option. Here again you will find the option to choose default OS. Choose the windows xp in it and then remove the tick from "Time to display list of operating system" and then press ok.
This method will also solve the problem.

Note:- This method can be found on internet every where but i have made some changes in the tutorial and made it more convinient to understand for noobs...

Your comments are welcome..

Share this post

Link to post
Share on other sites

Dude, I own you my life. Thanks. Also, I knew one could manage to configure boot options through there or through msconfig, but what I didn't knew is that you don't really need an OS somehow inserted in the disk to have the OS showing up in the boot options. And actually I never rly read what's inside that startup and recovery section, if I had given a little more attention to that, I'd repair it myself. I'm such a dumb.What gave me the problem was a mod version of windows called MicroXP (for instance, yes, I OWN an original version of XP, so what I did wasn't really piracy, was an alternative option for a MS customer) and that 'improved' XP has proven a total wreckage, and it failed (yes, failed) the first attempt to install windows, and I didn't notice I changed partitions the next try. So I thought: 'FORMATTING WILL KICK THE GODDAMNED GHOST OS AWAY'. Well, as you know, I was wrong. Your sollution was so simple and yet so efficient it makes me mad hahahaha thanks a lot, dude!

-reply by Kodama

Share this post

Link to post
Share on other sites
Default OSBoot Menu Has A Stuck Os


I try to merge my C drive (which contain my XP) with my another partition which having free space. Both are FAT 32. I got an error message that drive contains windows cannot merge with other drive. However after that during my start up I m getting 2 OS option and both are Default OS. Out of which the one selection doesn't work and it simply restart the laptop and the other one loading my windows XP. The cursor default selection is to the one which is not working hence during start up if I failed to make the selection the laptop keep on restarting.

Please help in overcoming this.

Share this post

Link to post
Share on other sites
Remote OS wonBoot Menu Has A Stuck Os

I found another solution that works. I'm using Windows Vista Home Premium 64 bit

1. Go to control panel

2. Go to Administrative Tools

3.Click on System ConfigurationĀ 

4. On the above tabs, click Boot.

5. On the boot lists, it will show the OSs that will also show up when u start your computer.

6. Click on the OS you don't want to show up and click delete.

7. Then hit Apply and OK. It will ask to restart your computer. Restart your computer.



-reply by Jetman777

Share this post

Link to post
Share on other sites
Vista RecoveryBoot Menu Has A Stuck OsI am using compaq core 2 duo laptop winth window vista home premium. Its backup is laid in my computer D drive. Shopkeeper told me whenever your window give problem, you can recover it by pressing F11 during bootup. I check it two or three times and sucessfully recover window to its previous date. But unfortunately, I install window 7 in F drive. After using some days I feel burdon and want to remove. I formated drive F, but during booting both window options are appear. By using above procedure, the option of window 7 I deleted and after restarting this option were not found. I was very happy. But when I need to recover Vista, after pressing F11, the option recovery set appears but do not start. The window normally start and I am unable to recover it. After this I opened Control Panel/Administrative Tool/Sys Config/Boot, The entry of both OS (Window Vista and Window 7) are present automatically. Pl help me in this regard to overcome on this problem. I will be very thankful to you for that.-reply by Farooq

Share this post

Link to post
Share on other sites

you may have accidentally removed the backup operating system.... Go back into the control panel where it shows which operating systems are on the computer. You should, i think, have two. one is windows 7, the other is the recovery system. IF you only have windows 7 then it seems you may have deleted the recovery one.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.