Jump to content
xisto Community
Sign in to follow this  

Cannot Open Display - Error

Recommended Posts

I basically have some problems in accessing xWindow applications(SAS and nedit in particular) in the server.


i get "Cannot open display" when i try to access nedit and other applications.


I did some findings on this and thought this might be of some help to you.

But I was not able to zero in on the problem yet.


The problem I guess, is the remote not able to enable the display to the server.

The display settings has to be set properly in the remote machine.


Commands I tried


setenv DISPLAY <server-name:display port>

xhost +



But nothing worked out. Some of the workarounds also need root access. So was not able to try them.

It would be great, if someone can help me out.











Share this post

Link to post
Share on other sites

And on whose server are those programs running? Is it yours, or someone elses? Because, maybe security settings don't allow for remote access to X server? Maybe it's a stupid quesyion, but hey, someone had to ask ;)

Share this post

Link to post
Share on other sites

i think the problem is because u are not the admin for the server.. u need to access using root login or try making a new user with all the rights and then access with that account (its only possible if you are the admin for the server)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.