Jump to content
Xisto Corporation
Sign in to follow this  
kevlar557

Dual Windows Boot

Recommended Posts

I was playing around with one of my old computers last night, and I put an old hard drive in my new system. I have XP on my master, and win 95 on my slave. Is it possible to be able to select what OS to boot from, without playing with cables or jumpers?

Share this post


Link to post
Share on other sites

Most computers ive used have a boot option key that you can press shortly after turning on the computer, you can usually select to boot from master or slave.if not, you could use a boot loader called GRUB.

Share this post


Link to post
Share on other sites

You can't really avoid messing with the jumpers - coz one drive HAS to be the Slave and other the Master. But assuming that your jumpers are configured accordingly, here's what you can do to get a dual-boot menu during bootup.

 

On the Master HDD which has WinXP, enable viewing of Hidden Files and Folders. Next check in the C:\ drive for a file named boot.ini. Here's what the file contains in my case:

[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)\WINNT[operating systems]multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect

That multi(0)disk(0)rdisk(0)partition(1).... part you see specifies which partition & folder to boot from and what the label appears as during boot time. All you've got to do is add one more line:

multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Microsoft Windows 95" /fastdetect

NOTICE how I've changed the disk(0) to disk(1) indicating your second physical Hard Drive. If Win95 is on the first partition of this disk, leave the partition(1) as it is... if it's on some other partition, replace this with a suitable value. Also the trailing folder has to be edited... For WinXP and 2000, this is \WINNT .. For 95 this should be changed to \WINDOWS or whichever folder your 95 is installed to. Also note that I've changed the label to "Microsoft Windows 95".

 

That's it. We're done. When you save the file, you might encounter some resistance as this is a file marked with Hidden, System & Readonly. In such a case, turn off these attributes, modify & save the file & turn the attributes back ON again.

 

Reboot and have fun... if it doesn't work the first time, then surely the record isn't pointing to the right partition & folder. Check up on your second drive, determine these factors and modify boot.ini accordingly..

 

All the best :P

Share this post


Link to post
Share on other sites

Grub is the same as the bootloader in windows, so it would be quite a way around to do so. I have grub as bootloader, but that is only because it came standard with the Fedora Core 3 installation that i put over win xp.

Share this post


Link to post
Share on other sites

try to use BIOS to select drive which you want to use. press F11 or something of this sort and select the 2nd HDD. it doesn't matter if it is master or slave...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.