Jump to content
xisto Community

Can't Install Catalyst 8.12 Or 8.11 On Intrepid

Recommended Posts

I am in trouble because I don't have 3D acceleration after I upgraded to Ubuntu 8.10. :)


I can't build the packages for the proprietary drivers (8.12 and I also tried with 8.11 - the only 2 that support Intrepid) for my ATI Radeon Xpress 200M integrated chip on my laptop, here's what I get when I try to build them (this is the older 8.11 release, but the same happens with the newer one too ): http://pastebin.com/f7991078c?


Too long if I try to paste it here, sorry


And I also get this when I try to run glxgears and/or anything that demands acceleration (either 2D or 3D):?


whiteeagle@whiteeagle-laptop:~$ glxgears

glxgears: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory whiteeagle@whiteeagle-laptop:~$


Here is the dir listing of /usr/lib/libGL:



whiteeagle@whiteeagle-laptop:~$ ls /usr/lib/libGL*/usr/lib/libGLEW.so.1.4 /usr/lib/libGL.so /usr/lib/libGLU.so.1

/usr/lib/libGLEW.so.1.4.0 /usr/lib/libGL.so.1 /usr/lib/libGLU.so.1.3.070200

/usr/lib/libGLEW.so.1.5 /usr/lib/libGLU.a

/usr/lib/libGLEW.so.1.5.0 /usr/lib/libGLU.so




Thanks very much guys, I hope we'll find a solution :)

Edited by miladinoski (see edit history)

Share this post

Link to post
Share on other sites

This appears to be the error in the installation:

#dh_shlibdeps -pxorg-driver-fglrx "-Xlib32" #dpkg-shlibdeps: failure: couldn't find library libGL.so.1 needed by debian/xorg-driver-fglrx/usr/sbin/atieventsd (its RPATH is '').
#Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
#To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
#dh_shlibdeps: command returned error code 512
#make: *** [binary-predeb-IMPL/xorg-driver-fglrx] Error 1
#dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2

There appear to be discussions here, here and here. Take a look and see if their solutions work for you. They are all a similar problem to yours, even if for slightly outdated versions of both Ubuntu and the driver. If not, you can always try contacting ATI for help.

Share this post

Link to post
Share on other sites

Thanks rvalkass for your kind response, I will gladly see the offered solutions, as I really am bothered by this problem because I can't play a single game or run Google Earth :D


I asked the same question as here on Phoronix forums and I did recieve 2 repsonses but their solving methods didn't work for my bad. :)


I am now actually looking at the Solution B from here and I will post my experiences here later.


Thanks again :)

Share this post

Link to post
Share on other sites

Nevermind everyone I solved it by removing the nVidia drivers, and reseting to mesa, and after that I installed the ATI drivers 'the Ubuntu way' rebooted, reverted to a working backup of xorg.conf which I used in the past, running aticonfig --initial and rebooting.Now I get this when I run fglrxinfo in terminal:

whiteeagle@whiteeagle-laptop:~$ fglrxinfodisplay: :0.0??screen: 0OpenGL vendor string: ATI Technologies Inc.OpenGL renderer string: ATI Radeon Xpress SeriesOpenGL version string: 2.1.8201 Releasewhiteeagle@whiteeagle-laptop:~$
As is to me, this question is resolved. Thanks rvalkass, a lot! :) Edited by miladinoski (see edit history)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.