Jump to content
xisto Community
Sign in to follow this  

I'm Frustrated

Recommended Posts

Im not to sure if this is the right place to post. But if i did post it at the wrong place can someone direct me to where i am supposed to post(thanks in advance)Ok here goes, i had to reformat brother computer due to some security breach cause by my idiotic friend who was doing a file transfer from another com. Brother's windows crashed and i tried rebooting numerous time and i couldn't get passed the loading screen. So i reformat brother's com and reinstalled windows and did a dxdiag and found that my directx was at 9.0b. I need 9.0c as a requirement for a game and i thought thank god that game which i had to reinstall came with a directx9.0c driver. So i proceed with the process of installing the driver and once the status bar got to the point where it should start copying files and finish the installation with a reboot, the whole installer just jumped immediately to click Finish to complete. So i thought wow that was fast, and so i click finished and nothing happened, i went and reboot my com anyway and did a dxdiag again and i still see the driver version as 9.0b i tried numerous times, downloaded numerous programs, and even updated my vga card which in the new version came with a 9.0c direct x driver which should be properly installed into my com. But after two days of reformatting reinstalling windows, reinstalling the drivers, im still stuck at 9.0b the reason why its at 9.0b is that brother's system driver cd came with 9.0b as default so when i installed all the system drivers it got updated to 9.0b i tried thrice by not installing that 9.0b driver and proceeded to install the 9.0c driver immediately.But when i did a dxdiag its at windows default directx8... So please if anyone could shed some light into this matter please i pray help me. This is already the third day of me trying to install the directx9.0c to no avail. thanks for those who post a solution for my problem in advance. thank you so much.Thanks for all replies

Share this post

Link to post
Share on other sites

Have you tried running the game using directx 9.0b? Sometimes the computer may not show you the correct version, but the game would still run, i've learned from experience that usually if you are within a somewhat close range the game should run, I don't follow minimum specs all that much; however, if the game doesn't run, I would suggest going to the directx website and downloading the 9.0c package from them to install, the link is below.

Click me for dx9.0c

hope this helps

Share this post

Link to post
Share on other sites

I would try downloading DirectX 10 since that is the current version and would most likely work as well, but if memory servers me correct when asked to install the DirectX on some games don't because of the fact your computer will be running the most current. However, I did find a solution on this page. If that procedure doesn't pan out then try this link, as it seems to be a more sure thing then the other link. Like I said I would download and install DirectX 10 since it is backwards compatible if I remember correctly.

Share this post

Link to post
Share on other sites

I would try downloading DirectX 10 since that is the current version and would most likely work as well,

Actually bad idea... Direct X used to be backwards compatible, meaning newer versions of Direct X would still run games that required older versions. When DirectX 10 came out, it was built for a different graphics architecture - specifically Windows Vista.
Make sure your 'hardware acceleration' is set to full under The display properties > advanced. I googled around and found some solutions for you aswell.

Go to http://download.cnet.com/windows/ and in search put directx. You will get all direct downloads from 8.0 to 9.0c. Download the complete dx 9.0c redist program (33meg) and save file to a folder on hd. Then click on directx_9c_redist.exe and your direct x 9c will be installed. This way you are installing dx 9c from hard drive and not microsoft web site.. Note this is the redistribution dx9c that you use to install ofline

If that does work... here is an alternate route to go.

You need both the 9.0b and 9.0c full versions. Unzip both version to its respective folder. Then copy and paste the following from 9.0b to 9.0c:

Then run the dxsetup from 9.0c folder. follow instructions..

and a third solution...

You need:Directx 9b Full
Directx 9c Full
Directx Eradicator 2.0

Use Dxdiag to make shure the directx 9b is Ok.

1. Make a restore point using windows system restore
2. Create a folder and unzip directx 9b to it
3. Create another folder and unzip directx 9c to it
4. Replace the files dxsetup.exe, dsetup32.dll and DSETUP.dll from 9.0b to 9.0c
5. Use DxEradicator 2.0 to unistall the Directx 9b in your system (System will reboot with some errors)
6. Install Dxsetup from de folder 9c (System will reboot)
7. Using system restore, restore to the point you created on the step 2
8. run Dxdiag and its done.

A file Directx Rollback Wizard will be created on your desktop - You can delete it !

That worked for me, I hope it works for you.

More information here:

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.