Jump to content
xisto Community
Sign in to follow this  

Probs With Mysql

Recommended Posts

$dbhost = "";$dbuname = "nuke";$dbpass = "****";$dbname = "nuke1";$prefix = "dlclan_";$user_prefix = "dlclan_";$dbtype = "MySQL";$sitekey = "SdFk*fa28367-dm56w69.3a2fDS+e9";$gfx_chk = 0;$subscription_url = "";this is my current setup for my database.the database is called nuke 1 and the user is dlclan_nuke what am i doing wrong as my site says that php nuke database probsalso on my upload of 7.3 there is no install folder or install.php wtf is goin on :S

Share this post

Link to post
Share on other sites

is that for the php code to connect? if so you got too much for it. for connecting you only need$dbhost = "localhost"; (if on Xisto use localhost)$dbuname = "username";$dbpass = "****";$dbname = "dbname";(correct me if im wrong)hope this helps if i understand right.

Share this post

Link to post
Share on other sites

it might be helpful if you include your site so we can

check the errors first hand :P


anyway, try double-checking on your user permission

settings at cpanel. if you created a db with the correct

user permission settings, you will be presented with the

correct connection strings to follow in your configuration

(most specifically, for the $dbuname & $dbname you must

use). i'm using uni.cc so my mysql connection string

automatically prefixes my uni.cc subdomain (serverph)

to the $dbuname & $dbname. (i don't know if it works the

same way for those with Xisto subdomains.)


a sample connection string (generated from my own cpanel):

$dbh=mysql_connect ("localhost", "serverph_dbuser", "<PASSWORD HERE>") or die ('I cannot connect to the database because: ' . mysql_error());

mysql_select_db ("serverph_db");

sample config (which i used for my site) following the sample

connection string generated in my cpanel:

$dbhostname = "localhost";  //hostname dbserver

$database = "serverph_db";    //database name

$mysqluser = "serverph_dbuser";  //mysql username

$mysqlpassword = "********";  //mysql password


if i were to set my config following your coding variables, it would

appear as:


$dbhost = "localhost";

$dbuname = "serverph_nuke";

$dbpass = "********";

$dbname = "serverph_nuke1";


(note: the serverph_ is prefixed in the values for the

$dbuname and $dbname variables, because serverph is my

uni.cc subdomain. if your subdomain is toohot for example,

toohot_ will be prefixed. just change your configuration



most mysql problems arise with incorrect user permission

settings, so you might want to check that first. be sure you

have a nuke user with permission to use your nuke1

db in your cpanel. after that, reconfigure the values in your

variables to reflect the correct $dbuname and $dbname.


and if you're still having problems after that, you might want

to play around first in setting up your mysql db with a simpler

php script. after you successfully set it up on a simpler script,

you can then go into setting up phpnuke more confidently. :D

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.