HOME       >>       Websites and Web Designing

Linux Problem X-window doesnt work


warbird1405241485

I tried to install Linux Enterprise on my system a while ago, I maked a dual-boot system together with Windows XP and installed it. When I tried to start Linux it all worked until I logged in and tried to start the X-window. Does someone know what's the problem is it my graphical card maybe? I've got a ATI Radeon 9800 Pro card.-jeroen-


miCRoSCoPiC^eaRthLinG

Which Linux dude ? I haven't heard of any distro named simply Linux Enterprise!!BTW - did you configure your video card properly? As far as I know if X cannot detect your card properly, it'll fall back to a basic VESA compatible mode...


warbird1405241485

Sorry for that, I didn't put it in the post, it's Linux Redhat Enterprise


Giniu

Try doing what m^e said - reconfigure your video driver... try using xorgconfig if you isn't familiar with xorg.conf file...(I never used new RedHats - is it running on XOrg or standard XFree? Correct me someone ) also try installing drivers for your card from ATI page... Hope you would get your X's running soon...


qwijibow

Without an error message best we can do is guess.

How old is the distro, what version of redhat enterprise ?
Sometimes, i fine old redhat installers detect an ATI card, and setup the X server to use the generic r128 driver (which in older versions may not work with newer ATI cards)

Either install the graphics drivers from ATI, or re-configure the x server to use the slower, (but failsafe) vesa driver.

in /etc/X11/XFree86.conf or /etc/X11/xorg.conf
look fir the line

Driver "r128"

and replace with
Driver "vesa"

and restart X..

But like i said, this is a complete guess, and will remain this way untill you post the error message...

or maybe the last 100 lines of the X server log in /var/log/

hatim

Well in /var/log/xorg.0.log you need to search for EE or errorI would recomend to you that you get hold of Latest KNOPPIX CD. It will boot and detect a suitable setting for your x. You can then copy the xorg.conf to your /etc/X11 folder. But It may not give you the best 3D setup. It takes time to setup latest graphics card with full 3d support especially from ATI.hope it helps..ask me if some thing is not clear.PS: in knoppix ..xorg.conf file comes in /tmp as it is made every time.


qwijibow

downloading 700 meg live cd is hardly an effective soluton to fix a possable xorg config file porblem.


xboxrulz1405241485

Maybe you should try installing another Linux distribution. I have always suggest SuSE Linux, you should use it too. Installing it and making it run was very very easy!xboxrulz



VIEW DESKTOP VERSION REGISTERGET FREE HOSTING

Xisto.com offers Free Web Hosting to its Members for their participation in this Community. We moderate all content posted here but we cannot warrant full correctness of all content. While using this site, you agree to have read and accepted our terms of use, cookie and privacy policy. Copyright 2001-2019 by Xisto Corporation. All Rights Reserved.