HOME       >>       Websites and Web Designing

Form Pre-Fills Wrong Login Name A cookie problem?


mrdee

My problem is quite difficult to explain, but I will give it a try anyway, as it is a very annoying problem.It all started after Xisto had a suspected server session error, one day, about two weeks ago, none of my forms on my website worked anymore, and other PHP scripts would not run properly neither.The reason why I mention the suspected server session error is because I sent a log of the error messages my form pages generated to the author of my form building software, and he replied they clearly indicated a server session error.Anyway, now for the problem itself:In most of the scripts it was resolved automatically, but, before, when I had a script involving a login screen, it pre-filled my username field with login names that belonged to other forms, and nothing I could do to change it, when I typed in the correct username, it automatically reverted back to what was pre-filled, obviously leading to a "Wrong username or password, please try again" error message.Now, this morning, I tried to log in to a section of my site which I had not used for a while, the username for that particular section is "admin", yet, as soon as I touch the username field, it gives a drop-down saying "Admin".When I go back to the field and change it to "admin", it stubbornly keeps reverting back to "Admin", hence leaving me unable to login.What I was wondering now is: would this be due to a cookie that started playing up after the server error?It looks like that to me, as, as far as my knowledge goes, cookies are a means of remembering data for a certain website or part thereof, so, could it be a cookie of one part of the login data that has taken over for all of them?Does anyone recognise this problem, or has anyone experienced something like that before?If anyone knows a solution, I would be very grateful to hear about it.I apologise for not being able to explain matters more clearly, but I tried to describe the error to the best of my ability, due to my limited knowledge.Thank you.


anwiii

what browser are you using? i use firefox. if you use firefox, i know there is an option to remember form data. have you already tried removing that option under your privacy options?i can't talk about other browsers as i only use firefox.


mrdee

Yes, I use Firefox too.I will give that a try, although, the form I tried this morning was not accessed for a long time and should have been (after maintenance and cookie clearing etc. in the past) been forgotten by now.But, OK, I'll have a look.


mrdee

Oh dear, that has made matters worese.Now the logins that were fixed have stopped working again.


anwiii

ok, but the issue wasn't about the forms that were already fixed. that's a whole seperate issue. we need to figure out the problem which allowed other problems to occur. i don't know what your other issues are. have you tried clearing all your browsing history? this problem is on your side since just changing your browser setting affected other things.so in my opinion, you need to delete your browsing history including cookies or delete any specific information specifically stored when entering form data. you mentioned your username as "admin" but it is autofilling as "Admin" which tells me some of the history is confusing itself. i think you need to clear your history fully and see if that solves the problem.just because you turned off the security option to not remember form data doesn't mean the form data was deleted. but now you can clearly see that this is on your side. not a server issue as this was a question you had.also, i don't advise clearing individual history specifically to the website your form is on since it's autofilling something different. that's why if it was me, i would delete ALL history since whatever it is that is having a problem distinguishing what form you are actually using and is being displayed.does anyone else have access to the computer you are using? have you ever made a mistake in logging in and entered the wrong form data? if you had firefox set to remember form data, it's going to remember all the wrong logins too.so for now, just click on tools and click on clear recent history. uncheck everything except for the form and browsing history and clear it all.....


mrdee

Thanks, anwiii,I shall look into all those options.One thing I know is that nobody else but me has attempeted any logins on my machine.Fortunately, I kept my cool and just logged in using Internet Explorer 9 (don't use it normally, but do have it on my machine, fortunately).Doing this, the login worked, and when I went back to Firefox I could log in first time as well.(Maybe that rings a bell, don't know?).Anyway, thank you for your help so far, and I will carefully look through all your other suggestions too.



VIEW DESKTOP VERSION REGISTERGET FREE HOSTING

Xisto.com offers Free Web Hosting to its Members for their participation in this Community. We moderate all content posted here but we cannot warrant full correctness of all content. While using this site, you agree to have read and accepted our terms of use, cookie and privacy policy. Copyright 2001-2019 by Xisto Corporation. All Rights Reserved.