Jump to content
xisto Community

Laptop Nec Versa S900 Won't Boot CMOS battery? power supply? mb problem?

Recommended Posts

Background story



So I have this 6-year-old laptop, a small 12" from NEC (Versa S900) which started to slow down at times, then more often until it was clear the problem was related to the hard drive. Finally it could not boot off the hard drive and you could hear sounds/ticks coming out of the hard disk. I left it alone for a few months powering it up occasionally to see if by any chance the hd would fix itself... eventually it started rattling every time the computer was powered up. In the meantime I booted the computer several time with Bart PE live WinXP CD, trying to find a way to use the computer without hard drive. I considered installing XP on a USB pen drive as reported by others, eventually I realized the BIOS did not support booting from USB drive (at first I thought it did, but I overlooked the fact it was USB FDD i.e. floppy drive not USB disk/pen).


Changing the hard drive



I got a working hard drive and replaced it. Went into the BIOS, the new hard drive was correctly identified, set boot sequence to CD-ROM first and HDD second and rebooted. First off I didn't insert any CD and as expected I got a message that there was no booting device. That message somehow looked unusual, stating something like "choose the proper boot device" instead of "non-system disk, replace and press a key". I thought that might depend on a different BIOS. I then rebooted with a WinXP boot CD inserted and to my surprise I was presented with the same message (i.e. no boot disk found). I rebooted a few times with the same result. I am quite sure that CD works as I used it many times, however I thought it may be damaged or something and I tried with another one. I could not see the result because by now the laptop wouldn't boot at all.


Current problem



So now I have a laptop that doesn't boot at all. When I press the power button the power LED lights up and the HD is heard starting as well. One or two seconds later the power is cut off, the HD stops and everything goes silent. After one or two seconds more the HD starts again and so does the LED. However nothing happens after this. Through the whole process there is no activity on the screen (no flickering, nothing) and the fan also does not start. The same behavior seems to happen regardless of the power source (AC, battery or both). Very occasionally (1 out of 20 perhaps) the fan starts and the power drop does not occur, the boot up sounds quite normal except that there is not activity on the screen whatsoever, and very limited activity on the HD.


What I tried



First off I thought the LCD might be not working so I tried connecting an external monitor, no activity on that one either. In case it could be a display card problem, anyway I don't think that is the case because as I said the strange behavior is not limited to the blank screen.


What happens seems similar to when the battery is almost empty and cannot sustain the computer starting up. I checked the AC adapter and the output seems alright, however I could not test it while loaded. Anyway I don't think that is the problem because the battery can be seen charging (red LED) and after sometime the charging process stops. At this point the battery should have at least a little bit of charge left. The battery could power the laptop for over an hour before, so it should still be in good working condition.


I removed the CD drive (which comes out easily) to see if that caused any trouble. No luck.


Possible causes



I came down to two main candidates, an empty BIOS/CMOS battery or a faulty motherboard (possibly in the power supply part).


I read about the CMOS battery being necessary in the first stage of the boot process, telling the CPU what to do next. If the battery were really out of charge it would not be able to guide the boot process, so the CPU wouldn't know what to do. This is currently my main hope (i.e. a relatively easy fix) also because I noticed the clock in the BIOS was previously showing the wrong date. However the information I saved into the BIOS was still there a few days later. But multiple boots and the age of the laptop could have caused the battery to go empty.


A more serious problem could be lng somewhere in the motherboard, perhaps in the circuit which is supposed to provide +5 or -5 to the various components. It seems strange to me that this showed up exactly after I changed the hard drive, unless the malfunctioning of the previous HD had somehow put a strain on the power supply. Or the current HD draws to much current, which I find unlikely. Moreover I tried removing the HD, putting the old one back etc. with no results.


Your opinion?



Should I go on changing the CMOS battery (hope it is easily accessible) or do you think the problem really lies somewhere else?


Thank you for your time.

Share this post

Link to post
Share on other sites

A little update. It wasn't the CMOS battery... well it was because the voltage reading was definitely low (~1.5V), but changing to a new one doesn't seem to fix anything. The same behaviour is still displayed.I am guessing the problem is somewhere in the motherboard or the CMOS itself. I have taken out all removable stuff (RAM, wireless module, DVD drive, HDD, etc.) so I think I am going to try to find some voltage regulator on the motherboard and check if it is working. That's about all I can do I think without going into a specific electronic debugging process.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.