Jump to content
xisto Community
Sign in to follow this  

How To Disable Flashing In Windows Freecell note: for XP

Recommended Posts

Just a hack I've made in the past. I think I disabled the Game Over pop-up sometime as well, except I didn't write it down anywhere.


Disable Flashing in FreeCell


Windows FreeCell flashes the window whenever your available moves is equal to one. If you find the flashing annoying like me, this hack will banish it to the dark realms. (Wikipedia says Vista FreeCell doesn't flash the screen anymore!)


The guide:


We only need one download to get this working: Any generic hex editor (I'll use xvi32).

Download is here: http://forums.xisto.com/no_longer_exists/


Boot up XVI32.exe, and open the file at location C:\WINDOWS\system32\freecell.exe.


Hit Ctrl-R for find and replace.

You want to search for 0F847B010000 (hex string)

This is to be replaced with 909090909090 (also hex string)


Save. (You can either replace the original freecell.exe or use Save As.. to create a copy.)


Play! The annoying flashing should be gone now!

If you want to revert the change at a later date, simply replace in the other direction (i.e. 9090... to 0F84...)




When we replace the hex string, we are replacing it with a bunch of NOPs (90 in hex). These are instructions to do nothing. We are simply overriding the conditional statement [jump to a flash screen routine if one move left] with [do nothing].



Thanks for reading, Nab.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.