Jump to content
xisto Community

Processor Discrepancy

Recommended Posts

I have a: Dell d600 Petium M 1.6 XP PROATI RADEON 9000Saturday, I downloaded Age of Empires III trial. After installing, I ran the program and an error message popped up stating that I didn't have the necessary processor speed to run the game. It said my processor was running at around 500 Mhz (a high reading was just below 700 Mhz and a low reading was just above 300 Mhz). I thought that because it was a trial, they hadn't worked out the kinks. Yesterday, a friend lent me Star Wars Republic Comando and I received the same message. I called Dell support and after running a couple of tests, the gentleman I spoke to said, that I was running at my 1.6Ghz and there was nothing he could do. I've run several other games (Doom 3, Knights of the Old Republic, Far Cry) with no problems. What is it about AoE III and SW Republic Comando that is preventing me from playing these games? Are there processes running in Media Edition that are causing conflicts?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.