Honesty Rocks! truth rules.

How To Configure Apache And Iis To Work On The Same Computer?

HOME      >>       Websites and Web Designing

web_designer

i have APACHE installed on my pc, it is a free package from XAMPP. i use it to test the updates in my sites locally because all of them are using PHP and MYSQL. so it is obviously using the port 80.the problem began after i installed "microsoft visual web developer 2010 express" it has a built in server working with it like IIS. and since then when i try to open XAMPP but it is not working of course because "microsoft visual web developer 2010 express" is using the port 80 now. so i tried to change the port in http.config in apache to 8080, restarted apache, but still not working from the XAMPP control panal. even i tried to open it from bin folder but still get the error page when i try to access localhost. i am not sure if i am accessing the localhost in the right way or not, i tried writing the new port but it didn't work for me http://forums.xisto.com/no_longer_exists/
so what should i write in the browser now to open localhost using port 8080??


Iniyila

i have faced this problem many years ago and i should say with just editing the listen 80 line, the port still is 80 even if you restart your server. there is a line with "Server Name" part in it change port in that too but sometimes it doesn't work either. if it doesn't work you have many options :1. i remember when i faced this problem i changed all port related stuff in xampp directory using an editor and replaced them with 8080.2. using AMPstart for starting XAMPP server sometimes solves the problem. actually there are many other starters too like "XampStarter" or etc which you can try to see if you can access to your local server using them.3, there are many other options that i don't know :D .


web_designer

thanks for your reply Iniyila, i will try what you suggested. even it is a pain to change all that using the editor. but i should do that since i don't have another choice , i need both of them on my pc right now. so i will try and see.


web_designer

ok i fixed it and found the solutions, hope it will be useful for everyone

- open your httpd.config file from open C:> xampp>apache>config>httpd.config and search for those lines

# Change this to Listen on specific IP addresses as shown below to # prevent Apache from glomming onto all bound IP addresses.##Listen 0.0.0.0:80#Listen [::]:80Listen 80


change the port from 80 to 85 for example and save the changes.

- open the httpd-ssl.config file from :> xampp>apache>config>extra>httpd-ssl.config
and search for those lines

# When we also provide SSL we have to listen to the # standard HTTP port (see above) and to the HTTPS port## Note: Configurations that use IPv6 but not IPv4-mapped addresses need two# Listen directives: "Listen [::]:443" and "Listen 0.0.0.0:443"##Listen 0.0.0.0:443#Listen [::]:443Listen 443

And change it to 445 for example and save.

- search for those lines

# General setup for the virtual host DocumentRoot "C:/xampp/htdocs" ServerName localhost:443

And change 443 to 445 and save.

that's it.

restart xampp, and be sure to type the path for your htdocs folder in the browser not localhost because you are using another port now.

web_designer

ok, i manged to make apache works again with the iis or the builtin sever for microsoft visual web developer. BUT, and unfortunately BUT :( i couldn't make wordpress working on port 80 :(i found out that wordpress is only working on port 80 not any other port. so returned to the beginning again. if anyone had the same problem i hope he could help me with that. i will be appreciated.