Honesty Rocks! truth rules.

Can't Upload Pdf To Wordpress Dashboard

HOME      >>       Websites and Web Designing

web_designer

hi, i got this problem when i was trying to upload pdf file to my dashbord, in specific to media library. i got this error "missing temporary folder".even i did that just a week ago, and everything works fine. tried changing my wp-content chomed to 777, but it didn't work either.i want to know if anyone has the same problem in his wordpress, maybe it is a server problem, because i got the same error when i tried to upgrade to wordpress 9.2.so, any ideas, trappers??


anwiii

i have never had a problem uploading, ever. if you are having problems doing it through your dashboard though, you could always do it through your ftp program. and upload is an upload. doesn't matter how you do itedit: ohhhh! i just remembered. someone else had the same error message in wordpress. i think it was mahesh2k. he started a thread about it 4 days ago or so. talk to him about it to see if he resolved the issue and if you can resolve yours the same way.


web_designer

i have never had a problem uploading, ever. if you are having problems doing it through your dashboard though, you could always do it through your ftp program. and upload is an upload. doesn't matter how you do it
edit: ohhhh! i just remembered. someone else had the same error message in wordpress. i think it was mahesh2k. he started a thread about it 4 days ago or so. talk to him about it to see if he resolved the issue and if you can resolve yours the same way.


hay anwiii, as usual you are the first to reply, thank you again. i saw that thread but there is no solution till now. therefore i want to make sure if it is a server problem or what. any way, i will try ftp uploading and see.

truefusion

i want to make sure if it is a server problem or what.

It is a problem on the server's side and cannot be programmatically fixed through PHP, and uploading any file through any PHP script won't currently work, at least on those hosted on the gamma server.

Saint_Michael

Your not the only one who has problems with wordpress on this server as you cannot auto-update plugins along with uploading images and what not through posts. Rest assure that this issue will mention so it can get fixed asap.


anwiii

i think you had the right idea by changing file permissions in the meantim, but you would have to actually change permission to the folder it would upload to. that would be /wp-content/uploads/2010/03/ so if it were me, i would change all permissions leading to the "03" folder to 777. if you don't have an 03 folder, manually create one, and then try uploading through your dashboard. that actually worked for someone who had the same problem as you. unfortunately it also DIDN'T work for other people who had the same problem as you but it seems like it would be worth a shot. just be carefull when editing permissions because it could leave your site vulnerable if you don't know what you are doing.mahesh said he tried to edit his php.ini file. this seems to be a very common solution to the problem so i suggest you read the articles on that so you know what to change as a second step solution. i just don't know how he accessed that file. i can't seem to access mine. it doesn't show at all. but it involves unmarking a comment section and setting up a temp folder which you would have to point to. since i can't access my php.ini file, if that is in fact the solution, then support would have to do it for you if you can't see yours either. i am told the php.ini file is in your etc folder in your root directory. just below your public_html folderbut again, if worse comes to worse and you really need that file, just upload it manually for the time being if it is in fact a server issue. and if so, then i have to question why the servers aren't set up the same way for everyone to use the same way. but then, i noticed trap features slowly disapearing for no apparent reason too. go figure. no explaination from anyone on that.


web_designer

well, the issue here is so bad, what's wrong with trap and the server. i tried all the suggestions that anwiii said but no success.
i changed all the permissions of the folders from wp-content to folder 03, but no change. i tried to upload the files manually using ftp but i got this error when tried to copy the files from ftp folder to 03 folder

FileOp Failure on: /home--------70-562_MicrosoftÂŽ .NET Framework 3.5 ASP.NET Application Development(3).pdf: No such file or directory

also i couldn't find php.ini same as anwiii.maybe i should finally delete my post that related to pdf files.
i hope that error in server will be fixed soon.

anwiii

i wonder if you can just upload your pdf to your main folder "meinterest" and the edit the html to point to the file there. that will be a temporary fix until they fix your problems. then you can just paste it back to your 03 folder and edit your post when things are working properly. at least it wont prevent you from not having some fresh content.


web_designer

i wonder if you can just upload your pdf to your main folder "meinterest" and the edit the html to point to the file there. that will be a temporary fix until they fix your problems. then you can just paste it back to your 03 folder and edit your post when things are working properly. at least it wont prevent you from not having some fresh content.

well, i am not quite sure of understanding you completely. because i tried before to upload files by ftp and copy them to the meinterest folder but i got that error i mentioned before. i even found the same pdf files in the temporary folder which is o3 but i couldn't delete them from it, everytime i delete them i open it again and found the same.

simply, i can't delete or add files to my temporary folder in cpanal. in the same time, wordpress can't do that also. weird isn't it?

truefusion

Trap17 hosted accounts do not have access to the php.ini file do to the fact that this is shared hosting. mahesh most likely has paid hosting that allows him to access his own php.ini file.

Also, using ini_set() won't work, since the file would be uploaded before ini_set() gets called. However, the path for "upload_tmp_dir," by default, is empty anyway, which means PHP is relying on other information.

"meinterest"

Hmm? "meinterest"? You've just reminded me of something:
<?php echo $_ENV['TMPDIR']; ?>
Guess where that points to.

web_designer, is that the path of your account's tmp folder (run the code first)?

Xisto's cPanel username can only have a maximum of 8 characters, which means "meinterest" becomes "meintere". For security reasons, users are not allowed to access the directory of other users. This may explain why PHP declares the folder is missing. However, that doesn't explain why anyone who has access to that folder would receive that error—and, in fact, contradicts it.

Saint_Michael

The problem has been fixed and you should be able to upload and update your wordpress blog.


web_designer

thanks for fixing that error, and thanks for informing me about that. i could finally upload my pdf files even i got an error in wordpress after uploading. but i tested my site and ensured that the links work. also checked my media library and everything is alright. maybe it is a temporary error. any way, thanks for fixing the errors.


Saint_Michael

The issue stem from an Apache error and so it had to reloaded as for the kind of error that is anyone's guess, however, it affected the permissions and that is what cause the Wordpress issues.