HOME       >>       Programming

Desperate With Help On Php And Imap To Read Emails. Please!


shadow-x

Hi guys and girls. Im an old member who migrated to T17 but im back as it seems no-one at T17 can help. My problem is with PHP and IMAP...

im experimenting with php and IMAP to read emails on my local email server. My local email server is Mercury V4 which apparently does support POP and IMAP, i have confirmed the server is working by sending an email from the server using its internal send mail system and then checking that email using the Thunderbird client. the email was sent and received properly.

So i moved into the PHP area and done the basic connect code (the full code i used is below so check that, im sure its right, i basically copied it) which seemed to work, i got the result: "Resource Id #2" Should that be "#4" instead? One tut said i would get #4 so maybe the error lies here...

Anyway it connected and disconnected with no errors so i proceeded to use Imap_headers($connect); to get the headers of the emails.. Oh no.. It didnt work...The error detection code just told me it had failed with the variable i used to contain the header info returning a FALSE result and as such it just didnt work.... Any ideas? I really cant think of it. My PHPINFO tells me i have IMAP libs installed with the readout being:

IMAP c-Client Version 2004SSL Support enabled



And as i said the mercury mail server seems to support IMAP and POP so what else can it be? I have just updated to the latest version of PHP and checked that the PHP.INI file contains the right filepath for the IMAP DLL. Im all out of ideas! The code ive used is below and is virtually copied with the changing of a few variable names:


<?$user = "phptest";$pass = "test";$connect = @imap_open("{localhost}INBOX", $user, $pass)or die("Connection to server failed");echo $connect;$headers = @imap_headers($connect)or die("Couldn't get emails");$numEmails = sizeof($headers);echo "You have $numEmails in your mailbox";imap_close($connect);

Ive also just updated my email server to the latest version but no luck, ive disabled my firewall with no luck. Im really getting so damn annoyed with this and no-one seems to be able to help..Its just stupid! If you dont know what i can do cna you suggest a FREE, WINDOWS XP, mail server that i can try?

Im desperate here its driving me frikking mad.

Jared

I actually copy-and-pasted your code directly into a new file on my home server and replaced the user and pass variables with my own and replaced localhost with my mail server's name and it connected perfectly and correctly reported the number of emails in my inbox...

 

Also, the echo $connect; also returns Resource id #2 as well, which is interesting. I'm not sure that the id number really matters, it probably depends on how PHP is installed or what version you have... I'm not sure.

 

But as a result of this, I would have to think that there is a problem with your mail server... Either there's a connection problem--does your server require authentication?--or there's an error in the build, or something. Have you checked the troubleshooting manual? Because I'm led to believe that it's a problem with the mail server rather than PHP...

 

Hope this helps,

Jared



VIEW DESKTOP VERSION REGISTERGET FREE HOSTING

Xisto.com offers Free Web Hosting to its Members for their participation in this Community. We moderate all content posted here but we cannot warrant full correctness of all content. While using this site, you agree to have read and accepted our terms of use, cookie and privacy policy. Copyright 2001-2019 by Xisto Corporation. All Rights Reserved.