HOME       >>       Programming

Trap17 Flex Layout


Saint_Michael

After many weeks of ready, searching, googling, asking questions, coding minor debugging and some other stuff I have set up my first version of a Xisto portal application. Sad to say though that this sucker is loaded with errors and as has man browser related errors as well, but most liking stemming from the original error that I am at. Of course, the funny thing is that it works perfectly on my computer with obvious reasons since it is being locally tested, however I wanted this to be a desktop application and that way Xisto member would be able to have a Xisto portal application without the need to load browser. Then again though the security aspect of this application has zero so it has an unknown release at this time.

Error #2044: Unhandled securityError:. text=Error #2048: Security sandbox violation: http://forums.xisto.com/no_longer_exists/ cannot load data from http://forums.xisto.com/topic/5-how-many-of-you-are-using-adsense-at-ur-site-post-comments/. at Trap172/loadXML()[C:\Documents and Settings\Michael\My Documents\Flex Builder 3\Trap172\src\Feed1.as:9]at Trap172/___Trap172_Application1_initialize()[C:\Documents and Settings\Michael\My Documents\Flex Builder 3\Trap172\src\Trap172.mxml:3] at flash.events::EventDispatcher/dispatchEventFunction() at flash.events::EventDispatcher/dispatchEvent() at mx.core::UIComponent/dispatchEvent()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\UIComponent.as:9156] at mx.core::UIComponent/set processedDescriptors()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\UIComponent.as:1215] at mx.core::Container/createComponentsFromDescriptors()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\Container.as:3499] at mx.core::Container/createChildren()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\Container.as:2582] at mx.core::UIComponent/initialize()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\UIComponent.as:5341] at mx.core::Container/initialize()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\Container.as:2519] at mx.core::Application/initialize()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\core\Application.as:847] at Trap172/initialize()[C:\Documents and Settings\Michael\My Documents\Flex Builder 3\Trap172\src\Trap172.mxml:0] at mx.managers::SystemManager/http://forums.xisto.com/no_longer_exists/()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\managers\SystemManager.as:1639 at mx.managers::SystemManager/initializeTopLevelWindow()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\managers\SystemManager.as:2498] at mx.managers::SystemManager/http://forums.xisto.com/no_longer_exists/()[E:\dev\3.1.0\frameworks\projects\framework\src\mx\managers\SystemManager.as:2344

That is the error, and odds are it has to do with how I am exporting this for a release build the only things that are working properly that I am aware of is the search books and the nav menu.

As for browser related issues

Firefox 3 - Iframes do not load properly and RSS feed does not work
Opera 9.52 - Same thing
Internet Explorer 7 - RSS feed does not work

I am being told that firefox 2.0.0.17 and 3.1.2 are displaying the websites properly and so that is where I am at this time and so I will provide a link to the source code and if people who are interested can take a look and see what can be fixed and or cleaned up and of course the actual layout itself.

http://forums.xisto.com/no_longer_exists/

http://forums.xisto.com/no_longer_exists/


VIEW DESKTOP VERSION REGISTERGET FREE HOSTING

Xisto.com offers Free Web Hosting to its Members for their participation in this Community. We moderate all content posted here but we cannot warrant full correctness of all content. While using this site, you agree to have read and accepted our terms of use, cookie and privacy policy. Copyright 2001-2019 by Xisto Corporation. All Rights Reserved.