HOME       >>       Programming

Html Div Help [resolved] help with the divs in ipb


bthaxor

hey guys,

as you may know, i have ipb 2.3.4 set up on my site.

i am currently using the centura skin and like it a lot. i have customised the header bar in terms of the logo, however also want a slab of text linking to the forums home at the top of the banner.

i have so far managed to achieve this to work in firefox (see attached screenshot), however it just screws up in ie, opera and safari (i think).

the link is here

here is the code, both html and css, of the ipb header, and i have placed between stars the parts i have edited:

the css (only the edited part):#headerlink {padding: 45px;font-color: #FFFFFF;font-size: 24px;}#headerlink a:hover{color: #d7dadc;text-decoration:none;}#headerlink a{color: #ffffff;text-decoration:none;}

the html:<div id="hdr"><div id="hdr_rs"></div><div id="logo"></div><div id="hdr_body_ls"</div>***********<div id="headerlink"><a href="http://forums.xisto.com/no_longer_exists/; title="projekt|haxor forums home">projekt<b>haxor</b>: forums</a></div>************</div><table id="nav" cellpadding='0' cellspacing='0'><tr><td align='left' style='width:18px;'><img src='style_images/<#IMG_DIR#>/nav_ls.gif' alt='' /></td><td style='text-align:center;'><table cellspacing='0' cellpadding='0' align='center'><tr><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td><if="$this->ipsclass->vars['home_url']"><td><a href="{$this->ipsclass->vars['home_url']}">{$this->ipsclass->vars['home_name']}</a></td><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td></if><if="$this->ipsclass->vars['csite_on']"><td><a href="{$this->ipsclass->base_url}act=home">{$this->ipsclass->vars['csite_title']}</a></td><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td></if><!--IBF.RULES--><td><a href="{$this->ipsclass->base_url}act=Help">{$this->ipsclass->lang['tb_help']}</a></td><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td><td><a href="{$this->ipsclass->base_url}act=Search&f={$this->ipsclass->input['f']}" id="ipb-tl-search">{$this->ipsclass->lang['tb_search']}</a></td><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td><td><a href="{$this->ipsclass->base_url}act=Members">{$this->ipsclass->lang['tb_mlist']}</a></td><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td><td><a href="{$this->ipsclass->base_url}act=calendar">{$this->ipsclass->lang['tb_calendar']}</a></td><td valign='top'><img src='style_images/<#IMG_DIR#>/nav_div.gif' alt='' /></td><if="$component_links != """>{$component_links}</if></td></tr></table></td><td align='right' style='width:18px;'><img src='style_images/<#IMG_DIR#>/nav_rs.gif' alt='' /></td></tr></table>

please help if you are able to.

edit: the page works fine in safari, it is just ie and opera (ie-based) where it doesnt work properly.

NEVER MIND, ISSUE FIXED I HAD FORGOTTEN TO END A TAG...


jlhaslip

Topic is resolved.Please PM any moderator to continue this discussion. Until then, this topic is closed.



VIEW DESKTOP VERSION REGISTERGET FREE HOSTING

Xisto.com offers Free Web Hosting to its Members for their participation in this Community. We moderate all content posted here but we cannot warrant full correctness of all content. While using this site, you agree to have read and accepted our terms of use, cookie and privacy policy. Copyright 2001-2019 by Xisto Corporation. All Rights Reserved.