HOME       >>       Programming

Myodbc 3.51.11-2 And Ups Worldship Connection Problem


alexviii

Hi everyone! I am trying to set up an export map from UPS's WorldShip software to MySQL Server using WorldShip's built-in feature for this purpose and MyODBC 3.51.11-2 on Windows Platform (WinXP and Win2000). Basically this involves setting up an ODBC DSN to connect to the MySQL server and then setting up an export map from within WorldShip that uses the ODBC DSN. If everything is set up correctly and UPS WorldShip software can successfully connect to the MySQL server (as it is supposed to) one has the opportunity to define the mappings between WorldShip's (local) database table fields and corresponding MySQL database table fields (which were created beforehand). The problem I am running into is that everything works as long as the ODBC connector refers to the MySQL server host as 'localhost' or '127.0.0.1', and doesn't work otherwise even if the host IP address for the MySQL server refers to the same machine. In other words, say I have WorldShip and MySQL server installed on the same system with, say, fixed IP address 10.0.0.200. Then as long as I set up the ODBC DSN using MyODBC so that it refers to the MySQL host as 'localhost' or '127.0.0.1', everything works fine. But if insead I set the IP address as 10.0.0.200 (the IP address of the machine) and try to set up an export map from within WorldShip using the same process, then WorldShip comes back with an "ODBC Source 'xyz' is not valid for 'export'" error even though the ODBC connection tests okay when it is set up through the windows ODBC administrator. I have tried previous ODBC versions as well, but nothing seems to work. Not sure if this is an ODBC problem or a WorldShip problem (UPS can't help - as far as they are concerned this is an ODBC issue - I am not convinced yet). Has anyone encountered this problem before. Is there a work-around. I couldn't find any registry setting to tweak or any options to set that will make this work. Following is my setup: - UPS WorldShip 7.0 (for anyone who has used this) - MyODBC (3.51.11-2, 3.51.12, 3.51.04, 5.0 Alpha - none work) - MySQL: 4.1.10a-nt-extension: mysqli - Server installed on Windows XP Pro (also tried on Windows 2000 Pro) - MyODBC installed on Windows XP Pro as well as Windows 2000 Pro machines - MySQL Server configured correctly with remote access over the local network. Tried varying user / host / db permission settings. Everything works as expected but nothing works with UPS WorldShip when trying to make a remote connection to MySQL server. Please help asap. 10x



VIEW DESKTOP VERSION REGISTERGET FREE HOSTING

Xisto.com offers Free Web Hosting to its Members for their participation in this Community. We moderate all content posted here but we cannot warrant full correctness of all content. While using this site, you agree to have read and accepted our terms of use, cookie and privacy policy. Copyright 2001-2019 by Xisto Corporation. All Rights Reserved.