Honesty Rocks! truth rules.

Problems Installing Wordpress please help me thanks

HOME      >>       Websites and Web Designing

mra550

Hello Good day and bad day for me :( I got my host and new domain today wow its nice and I am happy in the first place
then I will install wordpress in it so I go to my cpanel and look for fantastico deluxe and I saw that the wordpress version of fantastico is 2.5 so it is outdated then I saw Softaculous so tried opening this one also and when I am trying to install the wordpress it says that the software needs a higher version and it said that I must report this to provider, so I didnt be able to install it again, I decided to manually upload it then I go to wordpress site and download the version 2.9.1 the new version of wordpress and then after downloading this one I check my domain name and I see some error like this one

Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /home/pinoyblo/public_html/wp-includes/classes.php in line ....

so I didn't be able to install it I google some solution and some said that I must reupload and some said that there is a missing }
in the classes.php file I do reupload, redownload and then I also do editing the classes.php and add a }
but when I am done still I am having that trouble so I decided to look for older versions and it might work properly,
I downloaded 2.8 versions and do delete the wordpress 2.9 in using my filezilla ftp and after uploading it
I got another error like this

Parse error: syntax error, unexpected $end, expecting T_FUNCTION in /home/pinoyblo/public_html/wp-includes/functions.php in line ...

ok this time it is the functions.php is the problem so I try to look the 2.7 version of wordpress and downloaded it I try getting the functions.php file on that version and when I overwrite the file and check for my site yes it is ok it setup the wp_config.php and when done typing my database name, password, and host, I click proceed and start wordpress install and when I do start it it only appears a white blank page I tried refreshing and changing browser but not work so I tried uploading the whole 2.7 version in my host when its done I again got an error :) this


Parse error: syntax error, unexpected $end in /home/pinoyblo/public_html/wp-includes/functions.php on line 2089

please help me guys :) I want to install it perfectly and it seems that I cant, but when I am trying to run the wordpress using my wamp or xampp it is working, I don't know what is the problem if the Xisto/Xisto - Web Hosting or the wordpress scripts
hope you can help me in this matter and hope the managements will resolve the issue regarding the softaculous so that I can easily install it in one click thank you :D

anwiii

delete your manual install and whatever folder you put it in. also delete any databas that was created(mysql)do the auto install of 2.5 in fantastico. don't use anything softalicious offers. that should be taken off the server.once you do the install of 2.5, you can then upgrade from there. this will be the EASIEST way for you right now until you learn to do manual installs. i am asuming you just want your blolg up and running as quick as possible?


mra550

Can I upgrade it online? mm let me try your suggestion :D thank you so much hope it will work, I tried so many fixes and still cant make it run :)


anwiii

just make sure to delete the database too. some people forget to do that when they uninstall and delete their folder where wordpress is. if you put it in your main folder though(public_html)....don't ever delete that one....just the files you put there....

there is a plugin you can download that will upgrade you automatically. no worries.....

Can I upgrade it online? mm let me try your suggestion :D thank you so much hope it will work, I tried so many fixes and still cant make it run :)



mra550

I got the plugin for the upgrade but it seems not working :) I can't activate it and says some error, I don't know what theproblem is if its me or the server