Honesty Rocks! truth rules.

Problem With Menubar In IE

HOME      >>       Programming

darran

I am getting real frustrated. Everything seems to work on Safari and FireFox but when it comes to IE, it just simply doesn't. I am tried for a good 2 hours now, and I really do not know what is causing the problem. Could you please have a look? Here is my site (not completed yet)

http://forums.xisto.com/no_longer_exists/


bthaxor

it works fine in ie7... i am assuming you are talking about the hover effect of the menu bar, and if that is the issue then yes, it does work on ie7. i dont have ie6 so i wouldnt know.i am a firefox fan, and i can also confirm it works on firefox 2.0.1.3.


jlhaslip

Can you describe the problem better than "it simply doesn't work".IE6 doesn't do png images properly and your header is a png image. There is a javascript solution for that, in case that is the issue.


darran

The problem was when I hovered the menu, the border below jumps. I haven't got to fixing the PNG problem yet. Sorry about that, I have already fixed the problem. Now I have another problem and that my content div height is not extending to the bottom of my content. Could you take a look? I have already set my height to 100% on the body, html and #content.Same website as above.Thanks in advance.


jlhaslip

Now I have another problem and that my content div height is not extending to the bottom of my content. Could you take a look? I have already set my height to 100% on the body, html and #content.

using FF2, take the height : 100 % off of the content. the 100% declaration says the content should be 100% of the "viewport" (window or Monitor). Instead, let the content flow to its natural length. if anything, use min-height to fill the display on short pages/.
I'll have a look at the menu now, again, b ut it worked fine in IE last time I checked.

Please specify the Browser you see the problem in. Thanks.

*edit*

had a look in FF2, FF3b5, IE 5.5,6,7,8. The menus all worked fine, so I cannot replicate the problem.

sonesay

http://validator.w3.org/check?uri=http%3A%ine&group=0

 

check your page on validator its got some miss match tags which I suspect is causing your clears not to work properly. I know for a fact miss match tags screws up CSS layouts so it might pay to try and correct any layout errors and see if that helps. Its the first step anyway.


darran

That solved my problem, thanks jlhaslip :lol:And I also validated my site, it has no errors now.


iGuest

Javascript menubar bg-image doesn

Problem With Menubar

 

I have a problem: I'm making a site with javascript dropdown menubar. It has a background image, because the colour alone would be boring.

 

It all worked fine and looked good with Firefox and Safari, but IE shows the menubar white! No background at all. The image is on .Jpg form. I've treid adding "position: relative;" but it had no effect. I tested it on IE6 and IE7, but doesn't work on either one.. :(

 

It works fine with only a bg-color, but when adding the image it shows all wrong. And there's also a white "flash" when entering the submenus by hover..Dunno where it's from either.. Can you help me?

 

-reply by Tiina